Jump to content

Welcome to DDR!

We are your Dumont Dunes community & information source!

New here? Join the community! (You must sign in to post.)

Returning users: Sign In with your display name or email address.

Troubles signing in? Please contact us. Forgot your password? Reset it here.

 

Sign In

weekend warrior - fuel pump


Guest bicket

Recommended Posts

hello all......i am a girl trying to figure out why my fuel pump keeps blowing fuses....any suggestions for a girl who doesn't know how to fix it and now my warranty is a big waste of paper...wa wa wa...we took it out for the weekend and the fuses kept blowing and all we were trying to use was the fuel pump. it is a 2008 weekend warrior...see my profile for a pic.

Thank you :freakin_nuts:

Link to post
Share on other sites

HMMMM our haulers seem to be doing the same time as each other. I went out to Utah a few weeks ago, worked fine, came back and went to get gas for the lawn mower, and same thing......

anyone else have this problem??

It was to fuggin hott to dive into it last weekend when I found out about this

Thanks :laughing:

Link to post
Share on other sites

We are having the exact same issue with our WW as well. We took it in to be looked at and was told it would be $800 to replace it. We didn't replace it, just keep extra fuses and foil on hand for now. :rainbow1: :banghead:

Any input is greatly appreciated.

Link to post
Share on other sites

I have a next level and some times the pump just wont run you can here it try to but just wont , I have never blown a fuse but do you think it could be the same problem?

that could actually be the ground connection on the pump itself....find where the ground is connected to the frame and see if that connection is loose. just tighten it

i climbed under my rig a couple months ago and tightened all ground connections, and things work much better than before :beercheers:

Link to post
Share on other sites

that could actually be the ground connection on the pump itself....find where the ground is connected to the frame and see if that connection is loose. just tighten it

i climbed under my rig a couple months ago and tightened all ground connections, and things work much better than before :beercheers:

How did you get under the trailer? Are your axles flipped or did you jack it up? :slap::idiot:

Link to post
Share on other sites

i wedged your fat A$$ between the ground and the frame, then poured gravy down your gullet until my fat a$$ could fit underneath

FAT A$$

:beercheers:

Ok, I'm still trying to figure out how you got your Jack in the box sized head and 4 chins under there though????

Link to post
Share on other sites
  • 4 years later...

not quite, metal key may not work. $44--ouch!. most i have found are $15. i will call gpi tomorrow and see

if they still have the replacement gears for the m-55. thanks

Edited by foolofsand
Link to post
Share on other sites

Why do you want to replace them? If they are binding, have your tried filing them down?

yep, sanded down and work great for now. just wanted a spare set in case they break. best i could find was $23 for gears and $13 to ship 1 ounce, i will wait

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...